Service disruption: Facebook Ads, July 11, 2023
Incident Report for Supermetrics
Resolved
The instability with Facebook Ads data source connector is now resolved. All systems return to and maintain normal operation.

Our team will continue to monitor and are prepared to take quick actions should any further unexpected load degrade performance.

Thank you for your patience.
Posted Jul 14, 2023 - 15:35 EEST
Update
We have observed improved system performance and positive outcomes. The majority of the Facebook Ads queries are working normally and most of the Google Sheets triggered queries operate normally without delays.

We are actively monitoring the situation. Our team will provide an additional update in the next 8 hours.
Posted Jul 14, 2023 - 11:26 EEST
Update
After implementing several fixes and improvements to the Facebook Ads connector to enhance query performance, we have observed improved system performance and positive outcomes. We are actively monitoring the situation.

Note: While closely monitoring the platform for any additional issues, there will be a slight delay in parts of the Google Sheets triggered queries. However, all other functionalities of Google Sheets for Facebook Ads should be operating normally. Our team will provide an additional update in the next 18 hours.
Posted Jul 13, 2023 - 12:56 EEST
Monitoring
We have implemented a number of fixes and improvements to the Facebook Ads connector to improve query performance and are seeing positive results as systems return to normal operation.

Note: Some Google Sheets triggered queries may remain delayed as we monitor the platform closely for any further issues. All other Google Sheets Facebook Ads functionality should be normal. Our team will provide an update within 18 hours and hope to resume normal operations for all triggers at that time.
Posted Jul 12, 2023 - 23:08 EEST
Update
Due to persistent issues, the scheduled refreshes of Facebook Ads queries in Google Sheets will experience a delay of a few hours. We are actively investigating and collaborating with Meta to identify the root cause and implement a solution that will restore the connector's normal functionality. Our team will provide the next status update within the next 18 hours. We appreciate your patience as we work towards resolving this incident.
Posted Jul 12, 2023 - 16:06 EEST
Update
Our investigation into the issue is making progress as we diligently work towards identifying the root cause. The development team is actively engaged in examining various leads that have surfaced during the investigation. We understand the importance of resolving this matter swiftly and are committed to finding a solution. Our team will provide the next status update within the next 6 hours. We appreciate your patience as we work towards resolving this incident.
Posted Jul 12, 2023 - 11:14 EEST
Update
The majority of queries are functioning properly, although a few queries are experiencing delays or failures. Our ongoing efforts involve investigating the underlying cause and finding a solution to restore the connector's normal functionality. We’ll provide an additional update in the next 18 hours.
Posted Jul 11, 2023 - 16:22 EEST
Investigating
Supermetrics is currently experiencing slowness with the Facebook Ads data source connector, leading to partial degradation of service. Our teams are urgently working to resolve the situation and return our service to normal. We’ll provide an additional update in the next 6 hours.
Posted Jul 11, 2023 - 10:21 EEST
This incident affected: Data sources (Facebook Ads).