Service disruption: Facebook Insights, November 7, 2023
Incident Report for Supermetrics
Resolved
Meta has fixed the underlying issue and we are now able to return data for reach-based fields for Facebook Insights.

For users of Supermetrics for BigQuery (Marketplace), please run a backfill for the affected dates (November 2 to November 6) following the instructions in How to backfill data in BigQuery (marketplace).

We sincerely appreciate your patience and understanding during this process. Should you have further questions about this issue, please don't hesitate to contact our support team.
Posted Nov 09, 2023 - 11:32 EET
Update
We're currently experiencing an issue with our Facebook Insights data source connector, causing some customers to encounter the below error message:

“(#100) The value must be a valid insights metric”

We have added a workaround for this that will stop fetching the reach-based metrics that cause the error (Total reach, Paid reach, Total reach on posts, etc.). This means queries that contain these metrics will now run, but will return empty values for these metrics.

This workaround is in place for Google Sheets, Excel, and Looker Studio destinations. We are verifying if it is safe to add to Data warehouse destinations, and we will provide an update once we confirm this.

The workaround will be removed once Meta has fixed the issue on their side.

Thank you for your patience and understanding while we work to resolve this fully.
Posted Nov 08, 2023 - 14:43 EET
Identified
We're currently experiencing an issue with our Facebook Insights data source connector, causing some customers to encounter the below error message:

“(#100) The value must be a valid insights metric”

The issue appears to be happening with queries using the Total reach metric or other metrics derived from reach.

We've reported the issue to their support team, and are working on a workaround that will allow queries to keep functioning if they include those fields.

We'll provide an update once we have additional details or have released the workaround.

Thank you for your patience and understanding while we work to resolve this.
Posted Nov 07, 2023 - 17:44 EET
This incident affected: Data sources (Facebook Insights).