Service disruption: Multiple data destinations, November 4, 2025

Incident Report for Supermetrics

Resolved

After a monitoring period of 24 hours we have determined the issue is no longer reproducible and no new issues related to the deployment of the fix have been detected.

We are confident the issue has been resolved, but in case you have any questions or are still experiencing issues related to this incident, please contact our Support team.

Thank you for your understanding in this matter.
Posted Nov 05, 2025 - 16:45 EET

Monitoring

The fix that we have deployed to all affected infrastructure has finished and we are seeing positive results back in our monitoring.

In case you are still facing the error, please do not hesitate to reach out to our Support.

We will monitor the issue for an additional 24 hours.

Thank you for your patience and understanding.
Posted Nov 04, 2025 - 17:19 EET

Identified

We are investigating an isolated incident causing erroneous "License Expired" notifications for valid customers across multiple data destinations.

A fix has been deployed and is currently underway across the affected infrastructure.

The impact is limited specifically to customers who encountered and reported this erroneous notification earlier today.
Customers logging in now or executing queries are not affected by this incident and should experience normal service functionality.

The estimated down time is estimated to be a maximum of an hour.
Posted Nov 04, 2025 - 15:30 EET
This incident affected: Data destinations (Supermetrics for Looker Studio, Supermetrics for Google Sheets, Supermetrics for Excel, Supermetrics API, Supermetrics for BigQuery (marketplace), Supermetrics for Snowflake, Supermetrics for Azure Synapse, Supermetrics for Azure Storage, Supermetrics for Amazon Redshift, Supermetrics for Amazon S3, Supermetrics for Google Cloud Storage, Supermetrics for BigQuery (Hub)).