Service disruption: Microsoft Advertising, June 13, 2025

Incident Report for Supermetrics

Resolved

The fix that was applied yesterday evening has shown to be effective and no further issues have been observed. This incident is now resolved.

If you continue to experience any issues with authentication related to the Microsoft Advertising connector, please reach out to our Customer Support team.
Posted Jun 14, 2025 - 15:03 EEST

Monitoring

A fix has been deployed and we are currently monitoring the results.
Posted Jun 14, 2025 - 00:34 EEST

Investigating

We are currently experiencing a partial degradation of the service where access tokens seem to invalidate after a short period of time.

We are currently investigating this with priority and will update you as soon as we know more.

Thank you for your understanding and patience.
Posted Jun 13, 2025 - 19:34 EEST
This incident affected: Data sources (Microsoft Advertising).