Service disruption: Twitter Organic, June 5, 2023
Incident Report for Supermetrics
Resolved
All service issues have been resolved. Supermetrics is working as normal.
Posted Jun 05, 2023 - 10:02 EEST
Investigating
We're currently experiencing issues that have impacted Supermetrics Twitter Organic connector. Our teams are urgently working to resolve the situation and return our service to normal.
Posted Jun 05, 2023 - 09:03 EEST
This incident affected: Data sources (Twitter Organic).