We are pleased to inform you that the issue affecting our Pricing Page has been resolved. You can now view pricing information and purchase Supermetrics subscriptions as usual.
We apologize for any inconvenience this may have caused and thank you for your patience.
Posted Jan 26, 2026 - 15:31 EET
Investigating
We are currently aware of an issue affecting the Supermetrics website, particularly the pricing page (https://supermetrics.com/pricing).
Our team is actively investigating to identify the root cause and implement a fix.
We will update this page as soon as we have more information. Thank you for your patience and understanding.
Posted Jan 26, 2026 - 14:54 EET
This incident affected: Supermetrics (Supermetrics Website).