Service disruption: Looker Studio, March 20, 2026

Incident Report for Supermetrics

Resolved

The issue causing "Address Unavailable" errors in Looker Studio dashboards has been resolved. Our engineering team identified the root cause, applied a fix, and has confirmed full stability through monitoring.

If you continue to experience any issues, please contact our support team.
Posted Mar 20, 2026 - 18:14 EET

Monitoring

Our engineering team has successfully identified the root cause of the issue and a fix has been applied. We are currently monitoring the situation to ensure full stability.

Should you continue to experience any issues, please don't hesitate to contact our support team.
Posted Mar 20, 2026 - 17:20 EET

Investigating

We are currently experiencing an uptick in "Address Unavailable" errors in Looker Studio dashboards.
Our team is fully engaged in diagnosing the root cause and is currently developing a fix to mitigate the impact.

We will share more details as soon as they are available. In the meantime, please feel free to reach out with any specific questions.

Thank you for your patience and understanding.
Posted Mar 20, 2026 - 15:04 EET
This incident affected: Data destinations (Supermetrics for Looker Studio).