Service disruption: Supermetrics for Facebook Ads, August 23, 2023
Incident Report for Supermetrics
Resolved
The issue that was impacting the performance of our Facebook Ads connector has been resolved.

We've been able to fully recover the functionality of scheduled refreshes, meaning all Facebook Ads queries on Google Sheets are now working normally.

If your scheduled refreshes previously failed, you can manually refresh them or wait until their scheduled time, and they will execute normally.

We appreciate your patience and understanding while we worked towards a solution.
Posted Aug 25, 2023 - 20:05 EEST
Identified
We have been working on recovering the performance of the Facebook Ads connector and have observed positive results. All Facebook Ads queries on Google Sheets are functioning properly when manually refreshed.

Some Facebook Ads scheduled refreshes on Google Sheets are temporarily not executed, but most of the scheduled refreshes are working normally. We've been able to process more scheduled refreshes, and we aim to keep increasing until we reach a full recovery.

In case your scheduled refresh fails, you can refresh the queries manually to update your report. Once the issue is fully resolved, all scheduled refreshes will resume functioning normally.

Our team is continuing to work together with Meta to resolve the issue and return all Facebook Ads functionality to normal levels. We’ll communicate another update within the next 8 hours. Thank you for your patience and understanding.
Posted Aug 25, 2023 - 11:28 EEST
Update
We've been able to improve the performance of the Facebook Ads connector.

Some Facebook Ads scheduled refreshes on Google Sheets are temporarily not executed, but most of the scheduled refreshes are working normally. In case your scheduled refresh fails, you can refresh the queries manually to update your report. Once the issue is fully resolved, all scheduled refreshes will resume functioning normally.

Our team is continuing to work together with Meta to resolve the issue and return all Facebook Ads functionality to normal levels. We’ll communicate another update within the next 18 hours. Thank you for your patience and understanding.
Posted Aug 24, 2023 - 13:12 EEST
Update
We continue actively working on resolving issues with Facebook Ads, and we see that in most cases the connector should already be functioning normally.

However, some slowness may be experienced for heavier queries and DWH transfers. Additionally, some Facebook Ads scheduled refreshes on Google Sheets are undergoing maintenance and are temporarily unavailable.

In case your scheduled refresh fails, you can refresh the queries manually to update your report. Your scheduled refreshes will resume functioning once the issue is resolved.

Our team is continuing to work together with Meta to resolve the issue and return all Facebook Ads functionality to normal levels. We'll communicate another update within the next 18 hours. Thank you for your patience and understanding.
Posted Aug 23, 2023 - 20:12 EEST
Investigating
Due to issues with heavy load on the Facebook API, Supermetrics is currently experiencing partial service degradation with the Facebook Ads data source connector. Some Facebook Ads scheduled refreshes on Google Sheets are undergoing maintenance and are temporarily unavailable.

In case your scheduled refresh fails, you can refresh the queries manually to update your report. Your scheduled refreshes will resume functioning once the issue is resolved.

Our teams are urgently working to resolve the situation and return our service to normal. We’ll provide an additional update in the next 6 hours.
Posted Aug 23, 2023 - 13:35 EEST
This incident affected: Data destinations (Supermetrics for Google Sheets) and Data sources (Facebook Ads).