Service disruption: Google Sheets and Looker Studio, February 26, 2024
Incident Report for Supermetrics
Resolved
Google has confirmed that the service disruptions with Google Sheets and Looker Studio have been resolved.

Thank you for your patience.
Posted Feb 27, 2024 - 08:33 EET
Monitoring
Google has reported that the service issues with Google Sheets and Looker Studio have now been resolved. We're seeing marked improvements in system health and are continuing to closely monitor to ensure that there are no further issues.
Posted Feb 26, 2024 - 19:46 EET
Identified
Google is still experiencing some issues, but you can load existing reports and data sources in Looker Studio. To browse and add new data sources to your report, please use https://lookerstudio.google.com/data?search=supermetrics

The Google Sheets sidebar is operational for the majority of users, although some users may experience loading issues.

Our teams are urgently working with Google to resolve the situation and return our service to normal. We’ll provide an additional update in the next 6 hours.
Posted Feb 26, 2024 - 16:02 EET
Investigating
Google is experiencing issues that may cause the Supermetrics sidebar not to load in Google Sheets and the home page and reports not to load in Looker Studio. Our teams are urgently working to resolve the situation with Google and return our service to normal. We’ll provide an additional update in the next 6 hours.
Posted Feb 26, 2024 - 11:13 EET
This incident affected: Data destinations (Supermetrics for Looker Studio, Supermetrics for Google Sheets).