Supermetrics for Facebook Ads, September 20, 2023
Incident Report for Supermetrics
Resolved
This issue has been resolved. If you continue to experience any issues with the Facebook Ads connector, please contact our customer support team for further assistance.
Posted Sep 27, 2023 - 18:30 EEST
Monitoring
Error rates have returned to baseline levels. We are continuing to monitor the platform closely to ensure there are no further issues. If this error persists for your queries, please review our article linked below which outlines steps you can take to avoid the error and reach out to our customer support team if you require further assistance.

https://support.supermetrics.com/support/solutions/articles/19000154617-facebook-ads-query-optimizations-to-reduce-errors
Posted Sep 26, 2023 - 21:36 EEST
Identified
We have implemented additional fixes and improvements to the Facebook Ads connector, and have eliminated most occurrences of this issue.

However, in some cases, particularly heavy queries may still return this error. We will continue to work with our partners at Meta to programmatically reduce the occurrences. We have created a support article that outlines steps you can take to simplify your queries and reduce the chances of getting this error: https://support.supermetrics.com/support/solutions/articles/19000154617-facebook-ads-query-optimizations-to-reduce-errors

If you continue to receive this error and the steps outlined in the support article are not helpful, please contact our support team.
Posted Sep 26, 2023 - 19:00 EEST
Update
We have implemented several changes and improvements to the Facebook Ads connector and are seeing error rates decline. However, failures still persist above our normal range, and we are continuing to work with Meta to investigate and resolve any remaining issues.
Posted Sep 25, 2023 - 17:24 EEST
Investigating
We're currently experiencing an issue with our Facebook Ads data source connector, causing some customers to encounter the below error message:

"Query failed: Facebook is currently having issues with their API. We failed to fetch the requested data with an error' job failed'. We suggest trying smaller queries until Facebook resolves the issues or please try again later."

Our teams are urgently working together with Meta to identify the root cause and return the Facebook Ads data source connector to normal functionality.

We'll provide an update once we have additional details related to this issue.
Thank you for your patience and understanding while we work to resolve this.
Posted Sep 20, 2023 - 19:58 EEST
This incident affected: Data sources (Facebook Ads).