Security Notice: Unintended sharing of reports through Looker Studio

Incident Report for Supermetrics

Resolved

We're pleased to inform you that Google has confirmed the resolution of the reported issue.

Our team has also conducted testing from our side and we can confirm that the issue is no longer occurring.

We hope this update clarifies the situation.
For any additional questions or if you require further assistance, please feel free to reach out to our dedicated Support team.
Posted Sep 02, 2025 - 13:02 EEST

Identified

We are currently aware of a data security related issue with Looker Studio where some users may see reports listed which are not related to their company. After initial investigation and collaboration with the Looker Studio team at Google, this has been confirmed to be a Google issue and unrelated to Supermetrics.

We have found that this can occur for users who use any Looker Studio template (not just Supermetrics Templates) where when making a copy of the template if the new report is set to “public” visibility this report could appear for other users who made copies of the same template.

We are currently actively working with our partners at Google to resolve this issue, but in the meantime we suggest checking your sharing settings for your Looker Studio dashboards and avoiding using the “public” sharing setting.

The bug report we have submitted to Google can be found here - https://issuetracker.google.com/issues/436116937
Posted Aug 04, 2025 - 19:25 EEST
This incident affected: Data destinations (Supermetrics for Looker Studio).