Service Disruption: Facebook Ads, April 18, 2025

Incident Report for Supermetrics

Resolved

Meta has resolved the issue on their end, and your queries should now run without problems. To ensure your data is up-to-date, please rerun your queries or backfill your data.

If you have any questions, please reach out to our support team in chat or at support@supermetrics.com

We appreciate your patience and understanding!
Posted May 07, 2025 - 12:08 EEST

Update

The issue has been addressed by Meta and we have therefore removed the temporary workaround we had implemented for all of our products.

All queries should be working as expected and the option to include deleted ads should be added in case you want to also fetch this data again.

We will continue to monitor all of our products’ activities closely.

Thank you for your continued patience, we will update you as soon as we are confident that this issue is resolved.
Posted Apr 29, 2025 - 13:51 EEST

Monitoring

The issue has been addressed by Meta and we have therefore removed the temporary workaround we had implemented for Google Sheets, Looker Studio and Excel.

All queries should be working as expected and the option to include deleted ads should be added in case you want to also fetch this data again in the aforementioned products.

The workaround remains in place for our other products. We will remove it for these as well once we are confident that the issue remains resolved.

Thank you for your continued patience, we will update you as soon as possible in regards to any changes.
Posted Apr 28, 2025 - 23:47 EEST

Update

We have now released a workaround for all of our products.

All queries are expected to work again.

Any previously fetched data on Friday when the issue occurred, might require a backfill to amend the data.

Please note that the “include deleted ads” setting is currently defunct due to this workaround. Deleted ads data may appear or disappear in your results depending on several factors. Typically, this data is more likely to be missing in detailed queries (like ad, ad set, or campaign level).

We're also still waiting to hear back from Meta regarding a potential fix on their end to resolve the issue.

Thank you for your understanding and patience, we will update you as soon as we learn more.
Posted Apr 24, 2025 - 12:39 EEST

Identified

We have released a workaround for our Google Sheets, Excel and Looker Studio product. We recommend to refresh your account data (please refer to our support article for these steps) before attempting new queries.
After this queries should run without any issue.
Please note that this makes the “include deleted ads”-function defunct due to the workaround.
Your deleted campaigns will also be marked with “deleted” if that is their current status.

The issue has also been reported to Meta and we’re awaiting further feedback from their side to resolve the issue.

Thank you for your understanding and patience, we will update you as soon as we learn more.
Posted Apr 22, 2025 - 14:36 EEST

Investigating

We are aware of an issue with the Facebook Ads connector causing some campaigns to not be returned when querying campaign level data. We are actively working with our partners at Meta to resolve the issue as soon as possible.

In some cases, enabling the setting ‘Include Deleted Ads’ has shown to be effective at returning the missing records.
Posted Apr 18, 2025 - 19:11 EEST
This incident affected: Data sources (Facebook Ads).