Service Disruption: Google Ads, August 2, 2024
Incident Report for Supermetrics
Resolved
Google has resolved the issue on their end and re-enabled reporting for the affected endpoint.

We have re-enabled the affected fields, confirmed that data is now flowing normally.

For Data Warehouse transfers that either failed or would have returned incomplete data due to the deactivated fields, we will be automatically backfilling this data. Please allow some time for this to complete due to the large volume of data and requests.

If you have any questions please reach out to our support team at support@supermetrics.com
Posted Aug 05, 2024 - 17:40 EEST
Identified
Google has provided the following update on their status page regarding the current issue.

"Starting on July 30, 16:54:38 PST, a small fraction of advertisers started serving ads for products from other Google Merchant Center accounts and were able to see those products in their Ads reporting. The serving issue was resolved on July 31, 11:27:35 PST. We temporarily paused access to certain reports on August 1. Products, Product Groups, and Listing Groups reports continue to be down across the web interface, API, and Google Ads Editor as we work to restore reporting accuracy for the impacted time period. Campaigns are serving as expected across all customers.

We are working with urgency to bring these reports back online and will provide an update as soon as we have more information. We will be contacting all directly impacted customers with further details on this incident. Thank you for your continued patience."

We remain attentive to their progress and will take action to restore the deactivated dimensions as soon as they are functional again. We will provide an update within the next 48 hours, or as new information becomes available.
Posted Aug 03, 2024 - 17:19 EEST
Update
We have isolated the affected fields and temporarily disabled them so that queries and transfers that contain these dimensions will no longer fail. Values for these dimensions will temporarily return as null.

The affected dimensions are:

Brand
StoreId
OfferId
MerchantId
FeedLabel
CampaignPriority
EnableLocal
VehicleInventory
CategoryL1
CategoryL2
CategoryL3
CategoryL4
CategoryL5
ProductTitle
ProductTypeL1
ProductTypeL2
ProductTypeL3
ProductTypeL4
ProductTypeL5
ProductCondition
CustomAttribute0
CustomAttribute1
CustomAttribute2
CustomAttribute3
CustomAttribute4
Language


We are closely monitoring the progress from Google, and once the issue is resolved we will revert this change so that the information can be backfilled.

We will provide additional updates within the next 24 hours.
Posted Aug 02, 2024 - 18:36 EEST
Investigating
Google is currently experiencing an issue that is impacting our Google Ads connector. This is causing queries that include product fields to fail with error message: ‘Unable to get response, please try again in a moment’

We’re actively investigating workarounds for the issue and monitoring closely when the issue gets rectified by Google.

You can view Google’s status updates here.

We'll provide an additional update in the next 24 hours. Thank you for your patience and understanding.
Posted Aug 02, 2024 - 17:16 EEST
This incident affected: Data sources (Google Ads).