Service Disruption: Service Outage, June 5th, 2025

Incident Report for Supermetrics

Resolved

We are pleased to inform you that the system-wide outage affecting all of our products has been resolved. All systems are now fully operational.

We apologize for any inconvenience this may have caused.

Thank you for your patience.
Posted Jun 05, 2025 - 14:55 EEST

Monitoring

We have observed improvements in our system regarding the issue affecting all products. Our team is actively monitoring the situation to ensure stability and promptly address any further issues.

We'll provide an additional update as soon as we learn more. Thank you for your patience and understanding.
Posted Jun 05, 2025 - 14:46 EEST

Investigating

We are currently experiencing a system-wide issue affecting all of our products.

Our team is actively investigating the root cause and working on a resolution.

This page will be updated as soon as more information becomes available.
Posted Jun 05, 2025 - 14:03 EEST
This incident affected: Data destinations (Supermetrics for Looker Studio, Supermetrics for Google Sheets, Supermetrics for Excel, Supermetrics API, Supermetrics for BigQuery (marketplace), Supermetrics for Snowflake, Supermetrics for Azure Synapse, Supermetrics for Azure Storage, Supermetrics for Amazon Redshift, Supermetrics for Amazon S3, Supermetrics for Google Cloud Storage, Supermetrics Uploader, Supermetrics for BigQuery (Hub)) and Supermetrics (Supermetrics Hub).