We are pleased to share a confirmed workaround for this issue: re-running your query with a reduced date range and removing today’s date from the range. This helps resolve this permission-related issue with our Google Analytics 4 connector.
Please note that while this workaround is effective in most cases, it may not resolve the issue in all scenarios.
Our team continues to work closely with Google to have the issue acknowledged and fully resolved on the API side.
We apologize for any inconvenience this may have caused. If you continue to experience issues after applying the workaround, please reach out to our Support team, and we will be happy to assist you further.
Thank you for your patience and understanding.
Posted Jan 27, 2026 - 14:17 EET
Investigating
We are currently investigating a potential permission-related issue with our Google Analytics 4 connector.
Some customers may encounter the following error when running Google Analytics 4-related queries or reports that include a filter on pagePath:
“Error: Google Analytics 4 failure Your query returned a data fetch error: 403 – User does not have sufficient permissions for this property.”
If you encounter this error, please try re-running your query or reducing the date range to see if it resolves the issue.
We'll provide an additional update as soon as we have more information. Thank you for your patience and understanding.
Posted Jan 26, 2026 - 11:28 EET
This incident affected: Data sources (Google Analytics 4).