Service disruption in Google Sheets and Looker Studio

Incident Report for Supermetrics

Resolved

Google has resolved the issue and we've seen system performance return to normal. This incident is now resolved.
Posted Apr 03, 2026 - 15:27 EEST

Update

We’ve received a confirmation from Google that an issue on their side has impacted Google Sheets add-ons and Looker Studio extensions.

They are actively working on a fix, and we will continue to monitor the situation closely in the meantime.
Posted Apr 02, 2026 - 13:44 EEST

Update

We are continuing to monitor for any further issues.
Posted Apr 02, 2026 - 11:22 EEST

Monitoring

We’re now seeing normal system behavior. Preinstalled add-ons are launching as expected, and script execution performance has returned to normal. We will continue to monitor closely.
Posted Apr 02, 2026 - 11:06 EEST

Update

We are continuing to investigate this issue.
Posted Apr 02, 2026 - 10:29 EEST

Investigating

We're currently experiencing issues that are impacting Supermetrics services in Google Sheets and Looker Studio.

Our teams are working to identify the problem.
Posted Apr 02, 2026 - 10:27 EEST
This incident affected: Data destinations (Supermetrics for Looker Studio, Supermetrics for Google Sheets).