Service disruption: Google Sheets, March 7, 2024
Incident Report for Supermetrics
Resolved
The issue that caused the queries to fail has been resolved. The root cause was identified and measures were taken to remedy the issue.

Thank you for your patience.
Posted Mar 07, 2024 - 10:27 EET
Investigating
We are currently experiencing a degraded performance in Google Sheets. This issue is causing most queries to fail.

We are currently investigating the root cause and looking for potential workarounds.

We'll provide an update within 6 hours. Thank you for your patience and understanding.
Posted Mar 07, 2024 - 09:46 EET
This incident affected: Data destinations (Supermetrics for Google Sheets).