Service disruption: Pinterest Ads, November 7, 2023
Incident Report for Supermetrics
Resolved
We’ve implemented a fix to overcome the issue with the Pinterest API and to make queries with campaign, targeting, and other breakdowns to work again. We are seeing queries returning to normal, and we will continue monitoring to ensure no further issues arise.

If this issue persists for your queries, or if data returned has any issues, please reach out to our customer support so we can investigate the issue further.

Thank you for your patience and understanding.
Posted Nov 08, 2023 - 20:41 EET
Identified
We're currently experiencing an issue with our Pinterest Ads data source connector, causing some customers to encounter the below error message:

"Error: Pinterest Ads failure (Your query took too much time to process. Please try again later.)"

Queries without dimensions or only using advertiser or date will typically work. Those with campaign, targeting, and other dimensions will likely fail with the above error.

We’ve narrowed down the issue to a problem within the Pinterest API and have reported the issue to their support team.

We'll provide an update once we have additional details related to this issue from Pinterest.

Thank you for your patience and understanding while we work to resolve this.
Posted Nov 07, 2023 - 12:29 EET
This incident affected: Data sources (Pinterest Ads).