The issue that impacted Looker Studio has been resolved. After extended monitoring we are no longer observing the loading or timeout issues in Looker Studio reports, and Supermetrics is functioning as expected.
We have also received confirmation from Google they are no longer observing the issue.
Thank you for your patience.
Posted May 23, 2025 - 09:57 EEST
Monitoring
We have observed improvements on Google's side regarding the issue affecting some Looker Studio reports. We are actively monitoring the situation for any further issues.
We'll provide an additional update in the next 24 hours. Thank you for your patience and understanding.
Posted May 22, 2025 - 16:53 EEST
Investigating
We are aware of an issue that is affecting some Looker Studio reports. Data is slow to load or timing out with errors such as “System Error” or “Data Set Configuration Error”. This appears to be an issue on Google’s side.
We are seeking a workaround and closely monitoring the situation.
We'll provide an additional update in the next 12 hours. Thank you for your patience and understanding.
Posted May 22, 2025 - 16:30 EEST
This incident affected: Data destinations (Supermetrics for Looker Studio).