Service disruption: 9/26/2025 - Google Sheets sidebar requiring some users to enter Captcha

Incident Report for Supermetrics

Resolved

Google has indicated that the issue should be resolved now.

Please reach out to our Support team if you're still experiencing issues.
Posted Sep 29, 2025 - 05:29 EEST

Monitoring

While Google has not confirmed a fix, we have seen system performance return to normal. We have also noted many (non-Supermetrics) users on Google forums report a restoration of services.

We are continuing to monitor closely for any updates. If errors continue for you, please alert our support team so that we can assist further.
Posted Sep 27, 2025 - 00:12 EEST

Identified

The error causing some users to see a Captcha when launching the Supermetrics Sidebar has been traced back to an issue that is currently being investigated by Google. An issue tracker for the matter can be found here - https://issuetracker.google.com/issues/447566703?pli=1

We are continuing to work with our partners at Google to ensure this is resolved as swiftly as possible.
Posted Sep 26, 2025 - 20:23 EEST

Investigating

We are currently investigating an issue where some users are being asked to enter a Captcha code to launch the Google Sheets sidebar.

If you have any questions, please reach out to our Support team at the link below.

https://support.supermetrics.com/support/tickets/new
Posted Sep 26, 2025 - 19:59 EEST
This incident affected: Data destinations (Supermetrics for Google Sheets).