The performance degradation affecting Supermetrics Hub has been resolved. Users should no longer experience slowness when accessing the platform.
We apologize for any inconvenience this may have caused.
Thank you for your patience.
Posted Mar 06, 2026 - 15:36 EET
Investigating
We are currently experiencing performance degradation, resulting in slowness when accessing Supermetrics Hub.
Our engineering team is actively investigating the issue to identify the root cause and implement a fix.
We apologize for any inconvenience this may be causing and appreciate your patience. We will provide an update as soon as more information is available.
Posted Mar 06, 2026 - 15:28 EET
This incident affected: Supermetrics (Supermetrics Hub).