Service disruption: Supermetrics Pricing page, October 23, 2025

Incident Report for Supermetrics

Resolved

The fix has been successfully implemented and resolved. We're pleased to report that the Supermetrics pricing page is working now without any issues.

This matter is now considered resolved, and performance is fully restored. Thank you for your patience and understanding.
Posted Oct 24, 2025 - 09:17 EEST

Investigating

We are currently investigating reports of an Internal 500 Error being returned when attempting to access the Supermetrics Pricing Page.

This issue is limited to users in the JAPAC (Japan and Asia-Pacific) region only. Other regions are unaffected.
Posted Oct 24, 2025 - 08:47 EEST
This incident affected: Supermetrics (Supermetrics Website).