Service disruption: Looker studio, May 10, 2023
Incident Report for Supermetrics
Resolved
The loading issue in Looker Studio has now been resolved. Looker Studio connectors are now working normally. Please refresh your dashboards to have all the latest changes reflected. Thank you for your patience.
Posted May 19, 2023 - 10:15 EEST
Update
Improved connector versions appear to perform significantly quicker. We are working towards releasing similar improvements to the rest of the connectors. We’ll continue to closely monitor the situation and provide another update within the next 12 hours.

If you have previously experienced slow loading with Looker Studio, kindly refresh your dashboards and get in touch with us at support@supermetrics.com to provide us with an update on whether the issue has been resolved.
Posted May 18, 2023 - 18:56 EEST
Update
Improved connector versions appear to perform significantly quicker. We are working towards releasing similar improvements to the rest of the connectors. We’ll continue to closely monitor the situation and provide another update within the next 12 hours.

If you have previously experienced slow loading with Looker Studio, kindly refresh your dashboards and get in touch with us at support@supermetrics.com to provide us with an update on whether the issue has been resolved.
Posted May 18, 2023 - 10:28 EEST
Update
We've rolled out an improved version of our Pinterest Ads and TikTok Ads connectors.

Additional connectors we have already rolled out an improved version of include Facebook Ads, Google Ads, Facebook Insights, Google Analytics, HubSpot, Instagram Insights, LinkedIn Ads, LinkedIn Company Page, Shopify, and YouTube.

We'll continue to closely monitor the situation and provide another update within the next 12 hours.

If you have previously experienced slow loading with Looker Studio, kindly refresh your dashboards and get in touch with us at support@supermetrics.com to provide us with an update on whether the issue has been resolved.
Posted May 17, 2023 - 22:38 EEST
Update
We’ve rolled out an improved version of the connectors listed below: Facebook Ads, Google Ads, Facebook Insights, Google Analytics, Hubspot, Instagram Insights, Linkedin Ads, LinkedIn Company Page, Shopify, and YouTube. Please refresh your dashboards to ensure the latest changes are reflected. We are actively working on rolling out the change to all of our connectors. Rest assured, we will closely monitor the situation and provide another update within the next 12 hours.

If you have previously experienced slow loading with Looker Studio, kindly refresh your dashboards and get in touch with us at support@supermetrics.com to provide us with an update on whether the issue has been resolved.
Posted May 17, 2023 - 10:32 EEST
Monitoring
We’ve rolled out an improved version of our Facebook Ads and Google Ads connectors. We'll continue to monitor the situation and will give a new update within the next 12 hours.
Posted May 16, 2023 - 23:17 EEST
Update
Unfortunately, the loading time issues in Looker Studio continue. We have a task force with Google investigating this issue with the highest priority.
Posted May 16, 2023 - 14:50 EEST
Investigating
Looker Studio is experiencing abnormally long loading times. Our team is communicating with Google to resolve the issue.

We kindly ask you to be patient while loading your reports.
Posted May 10, 2023 - 15:52 EEST
This incident affected: Data destinations (Supermetrics for Looker Studio).