Service disruption: Google Sheets scheduled refreshes, July 24, 2026

Incident Report for Supermetrics

Resolved

We've deployed a fix for the issue affecting scheduled Google Sheets refreshes and have confirmed that refreshes are completing normally. The root cause was identified as increased latency for triggers scheduling, which caused some runs to time out and fail.

This incident is now resolved. If you continue to experience issues with a scheduled refresh, please contact support and reference this incident.

Thank you for your patience and understanding!
Posted Jul 29, 2026 - 11:38 EEST

Investigating

We are aware of an issue affecting scheduled refreshes (automatic triggers) in Supermetrics for Google Sheets.

Affected users may see "Refresh failed: Please contact support" with a status of "Unable to connect" in the Manage Schedules panel.

Manual refreshes from the sidebar continue to work normally.

Our engineering team is actively investigating the root cause. We will provide an update as soon as we have more information.
Posted Jul 25, 2026 - 00:57 EEST
This incident affected: Data destinations (Supermetrics for Google Sheets).